HIER(7) OpenBSD Reference Manual HIER(7)
hier - layout of filesystems
A sketch of the filesystem hierarchy.
/ Root directory.
Alternate (backup) location for the root (`/') filesystem.
/bin/ User utilities fundamental to both single and multi-user envi-
ronments. These programs are statically compiled and therefore
do not depend on any system libraries to run.
/bsd Pure kernel executable (the operating system loaded into memory
/dev/ Block and character device files.
MAKEDEV Script for creating device files (see makedev(8)).
fd/ File descriptor files (see fd(4)).
/emul/ Base directory for alternate areas searched first when system
call emulation is in effect (see compat_bsdos(8),
compat_freebsd(8), compat_ibcs2(8), compat_linux(8),
compat_sunos(8), compat_svr4(8), compat_ultrix(8)).
/etc/ System configuration files and scripts.
localtime Local timezone information (see ctime(3)).
disklabels/ Backup disklabels (see disklabel(8)).
kerberosIV/ Configuration files for the Kerberos version IV
system (see kerberos(1)).
kerberosV/ Configuration files for the Kerberos version V sys-
tem (see kerberos(1)).
mail/ sendmail(8) configuration files (including
mtree/ mtree configuration files (see mtree(8)).
ppp/ pppd configuration files (see pppd(8)).
skel/ Example ``.'' (dot) files for new accounts.
/home/ Default location for user home directories.
/mnt/ Empty directory commonly used by system administrators as a tem-
porary mount point.
/root/ Default home directory for the superuser.
/sbin/ System programs and administration utilities fundamental to both
single and multi-user environments.
/stand/ Programs used in a stand-alone environment.
/tmp/ Temporary files, usually an mfs(8) memory-based filesystem (the
contents of /tmp are usually not preserved across a system re-
/usr/ Contains the majority of user utilities and applications.
X11R6/ Files required for the X11 window system.
bin/ X11 binaries.
include/ X11-specific C include files.
lib/ X11 archive libraries.
X11/ Default configuration files for X11
and companion applications (see
xdm(1), xkb(1), twm(1)).
man/ X11 manual pages.
bin/ Common utilities, programming tools, and applications.
games/ Useful and semi-frivolous programs.
include/ Standard C include files.
arpa/ C include files for Internet service pro-
kerberosIV/ C include files for Kerberos IV authenti-
cation package (see kerberos(1)).
kerberosV/ C include files for Kerberos V authenti-
cation package (see kerberos(1)).
crypto/ C include files for the cryptographic li-
ddb/ C include files for the kernel debugger
g++/ Include files for the GNU C++ compiler.
isofs/ C include files for the ISO standard file
systems (currently only cd9660).
miscfs/ C include files for miscellaneous file
netatalk/ C include files for the AppleTalk proto-
netipx/ C include files for the IPX protocol.
objc/ C include files for GNU Objective-C.
ssl/ C include files for the OpenSSL library
rpc/ C include files for remote procedure
calling (see rpc(5)).
scsi/ SCSI-specific C include files.
uvm/ C include files for the New and Improved
virtual memory interface.
vm/ C include files for the virtual memory
xfs/ C include files for the XFS file system.
dev/ Device-specific C include files.
machine/ Machine specific C include files.
net/ Miscellaneous network C include files.
netinet/ C include files for Internet standard
protocols (see inet(4)).
netinet6/ C include files for Internet protocol
version 6 (see inet6(4)).
netiso/ C include files for ISO standard proto-
cols (see iso(4)).
netns/ C include files for XNS standard proto-
cols (see ns(4)).
nfs/ C include files for NFS (Network File
protocols/ C include files for Berkeley service pro-
sys/ System C include files (kernel data
ufs/ C include files for UFS (the U-word File
lib/ Archive libraries.
libdata/ Miscellaneous utility data files.
libexec/ System daemons and utilities (executed by other pro-
auth/ Login scripts used to authenticate users (for
local/ Local executables, libraries, etc.
obj/ Architecture specific target tree produced by building
the /usr/src tree.
ports/ The OpenBSD ports collection (see ports(7)).
sbin/ System daemons and utilities (executed by users).
share/ Architecture independent data files.
calendar/ Variety of pre-fab calendar files (see
dict/ Word lists (see look(1)).
words Common words.
web2 Words from Webster's 2nd In-
web2a Additional words from Web-
List of proper names.
papers/ Reference databases (see
special/ Custom word lists.
doc/ Miscellaneous documentation; source for
most of the printed 4.3BSD manuals
(available from the USENIX association).
games/ ASCII text files used by various games.
groff_font/ GNU troff shared fonts.
info/ Texinfo source files.
ipsec/ IPsec example files.
lkm/ Example source code implementing several
lkm module types (see lkm(4)).
man/ Manual pages.
misc/ Miscellaneous system-wide ASCII text
termcap Terminal characteristics
database (see termcap(5)).
mk/ Templates for make (see make(1)).
sendmail/ Example files for sendmail(8).
vi/catalog/ Catalog files for the vi(1) text editor.
tabset/ Tab description files for a variety of
terminals; used in the termcap file (see
tmac/ Text processing macros (see nroff(1) and
zoneinfo/ Timezone configuration information (see
src/ BSD and/or local source files.
bin/ Source for files in /bin.
etc/ Source for files in /etc.
games/ Source for files in /usr/games.
gnu/ Source for files with GPL license.
include/ Source for files in /usr/include.
kerberosIV/ Source for Kerberos version IV.
kerberosV/ Source for Kerberos version V.
lib/ Source for files in /usr/lib.
libexec/ Source for files in /usr/libexec.
lkm/ Source for files in /usr/lkm.
sbin/ Source for files in /sbin.
share/ Source for files in /usr/share.
sys/ Kernel source files.
usr.bin/ Source for files in /usr/bin.
usr.sbin/ Source for files in /usr/sbin.
/var/ Multi-purpose log, temporary, transient, and spool files.
account/ System accounting files.
acct Execution accounting file (see acct(5)).
at/ timed(8) command scheduling files (see at(1)).
backups/ Miscellaneous backup files.
db/ Miscellaneous automatically generated system-specific
games/ Miscellaneous game status and log files.
log/ Miscellaneous system log files.
wtmp Login/logout log (see wtmp(5)).
mail/ User mailbox files.
named/ named(8) configuration files.
namedb/ Zone files.
preserve/ Temporary home of files preserved after an accidental
death of an editor (see ex(1)).
quotas/ Filesystem quota information files.
run/ System information files describing various info
about the system since it was booted.
utmp Database of current users (see utmp(5)).
rwho/ rwho data files (see rwhod(8), rwho(1), and
spool/ Miscellaneous printer and mail system spooling direc-
ftp/ Commonly ~ftp; the anonymous ftp root di-
mqueue/ Undelivered mail queue (see sendmail(8)).
output/ Line printer spooling directories.
uucp/ uucp spool directory.
Commonly ~uucp; public uucp temporary di-
tmp/ Temporary files that are kept between system reboots.
apropos(1), find(1), locate(1), whatis(1), whereis(1), which(1)
A hier manual page appeared in Version 7 AT&T UNIX.
OpenBSD 3.0 June 5, 1993